import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<order>\\d+)\\n(?<start>[\\d:,]+)\\s+-{2}\\>\\s+(?<end>[\\d:,]+)\\n(?<text>[\\s\\S]*?(?=\\n{2}|$))";
final String string = "1\n"
+ "00:01:35,418 --> 00:01:43,418\n"
+ "In 2015 an American archeological company\n"
+ "bought a military manuscript from the Han Dynasty\n\n"
+ "2\n"
+ "00:01:45,293 --> 00:01:49,501\n"
+ "It said\n"
+ "Roman soldiers went to China 2,000 years ago\n\n"
+ "3\n"
+ "00:01:49,918 --> 00:01:53,084\n"
+ "and the ancient city of Regum was bulit\n\n"
+ "4\n"
+ "00:01:53,918 --> 00:01:57,084\n"
+ "The archeological community believed\n"
+ "it was a fake";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}