import Foundation
let pattern = #"(?<order>\d+)\n(?<start>[\d:,]+)\s+-{2}\>\s+(?<end>[\d:,]+)\n(?<text>[\s\S]*?(?=\n{2}|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
1
00:01:35,418 --> 00:01:43,418
In 2015 an American archeological company
bought a military manuscript from the Han Dynasty
2
00:01:45,293 --> 00:01:49,501
It said
Roman soldiers went to China 2,000 years ago
3
00:01:49,918 --> 00:01:53,084
and the ancient city of Regum was bulit
4
00:01:53,918 --> 00:01:57,084
The archeological community believed
it was a fake
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)