use strict;
my $str = '1
00:01:35,418 --> 00:01:43,418
In 2015 an American archeological company
bought a military manuscript from the Han Dynasty
2
00:01:45,293 --> 00:01:49,501
It said
Roman soldiers went to China 2,000 years ago
3
00:01:49,918 --> 00:01:53,084
and the ancient city of Regum was bulit
4
00:01:53,918 --> 00:01:57,084
The archeological community believed
it was a fake';
my $regex = qr/(?<order>\d+)\n(?<start>[\d:,]+)\s+-{2}\>\s+(?<end>[\d:,]+)\n(?<text>[\s\S]*?(?=\n{2}|$))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}