package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]+`)
var str = `myhostname.somewhere.env.com
myotherhostname.somewhereelse.insomeotherplace.byh.info`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}