$re = '/^[^.]+/m';
$str = 'myhostname.somewhere.env.com
myotherhostname.somewhereelse.insomeotherplace.byh.info';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);