re = /^[^.]+/m
str = 'myhostname.somewhere.env.com
myotherhostname.somewhereelse.insomeotherplace.byh.info'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end