using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"com\.interactions\.(\d+)\.objectives\.(\d+)\.id";
string input = @"com.interactions.10.objectives.5.id";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}