re = /com\.interactions\.(\d+)\.objectives\.(\d+)\.id/
str = 'com.interactions.10.objectives.5.id'
# Print the match result
str.match(re) do |match|
puts match.to_s
end