$re = '/com\.interactions\.(\d+)\.objectives\.(\d+)\.id/';
$str = 'com.interactions.10.objectives.5.id';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);