# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http|https|ftp):\\/\\/(\S*)/<a href=\"$1:\/\/$2\">$1:\/\/$2<\/a>/ig;t' <<< "hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi "