re = /(http|https|ftp):\/\/(\S*)/i
str = 'hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi '
subst = '<a href=\\"$1://$2\\">$1://$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result