// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(http|https|ftp):\/\/(\S*)").unwrap();
let string = "hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi ";
let substitution = "<a href=\\\"$1://$2\\\">$1://$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}