package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ba+`)
var str = `ba baaa baaaaaaaa I'm a baaaaad sheeep.
babaaaaaaa baaaaaabooo booobaaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}