$re = '/ba+/m';
$str = 'ba baaa baaaaaaaa I\'m a baaaaad sheeep.
babaaaaaaa baaaaaabooo booobaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);