re = /ba+/m
str = 'ba baaa baaaaaaaa I\'m a baaaaad sheeep.
babaaaaaaa baaaaaabooo booobaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end