#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)eth.*?\b(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"Wed Mar 18 15:16:10 2015 eth0:1 109.224.232.219 up (not currently mapped)" & @CRLF & _
"Wed Mar 18 15:18:12 2015 eth0:1 109.224.232.219 down (not responding)" & @CRLF & _
"Wed Mar 18 15:20:46 2015 eth0:1 109.224.232.219 up (not currently mapped)" & @CRLF & _
"Wed Mar 18 15:22:52 2015 eth0:1 109.224.232.219 down (not responding)" & @CRLF & _
"Wed Mar 18 15:24:26 2015 eth0:1 109.224.232.219 up (not currently mapped)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")