# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?)eth.*?\b(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
test_str = ("\n\n"
"Wed Mar 18 15:16:10 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
"Wed Mar 18 15:18:12 2015 eth0:1 109.224.232.219 down (not responding)\n"
"Wed Mar 18 15:20:46 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
"Wed Mar 18 15:22:52 2015 eth0:1 109.224.232.219 down (not responding)\n"
"Wed Mar 18 15:24:26 2015 eth0:1 109.224.232.219 up (not currently mapped)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.