import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)eth.*?\\b(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})";
final String string = "\n\n"
+ "Wed Mar 18 15:16:10 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
+ "Wed Mar 18 15:18:12 2015 eth0:1 109.224.232.219 down (not responding)\n"
+ "Wed Mar 18 15:20:46 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
+ "Wed Mar 18 15:22:52 2015 eth0:1 109.224.232.219 down (not responding)\n"
+ "Wed Mar 18 15:24:26 2015 eth0:1 109.224.232.219 up (not currently mapped)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}