import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^P:\\\\(?:EVENT|OPPORTUN|ORGANISA|PERSON)\\\\(?:0(\\d)|(\\d{2}))\\\\(\\d{2})\\\\(?P<t>\\d{2})\\\\(?:(?:\\1|\\2)\\3\\4)0?\\.\\d+\\.\\w{3,4}$";
final String string = "\\\\v-mdt-new\\logs$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}