$re = '/^P:\\\\(?:EVENT|OPPORTUN|ORGANISA|PERSON)\\\\(?:0(\d)|(\d{2}))\\\\(\d{2})\\\\(?P<t>\d{2})\\\\(?:(?:\1|\2)\3\4)0?\.\d+\.\w{3,4}$/m';
$str = '\\\\v-mdt-new\\logs$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);