re = /^P:\\(?:EVENT|OPPORTUN|ORGANISA|PERSON)\\(?:0(\d)|(\d{2}))\\(\d{2})\\(?P<t>\d{2})\\(?:(?:\1|\2)\3\4)0?\.\d+\.\w{3,4}$/m
str = '\\\\v-mdt-new\\logs$
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end