using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'\\[0-7]{1,3}'";
string input = @"char x = '\077';
printf(""%c"", x);";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}