$re = '/\'\\\\[0-7]{1,3}\'/';
$str = 'char x = \'\\077\';
printf("%c", x);';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);