$re = '/\[~\{ (\w+) \}~\]/';
$str = '[~{ header }~]
<p>This is the home page</p>
[~{ footer }~]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);