re = /\[~\{ (\w+) \}~\]/
str = '[~{ header }~]
<p>This is the home page</p>
[~{ footer }~]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end