# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)\.(?!\d)|[^a-zA-Z\d. ]+//gm;t' <<< "the. book - 5. cost 7.55 dollars."