$re = '/(?<!\d)\.(?!\d)|[^a-zA-Z\d. ]+/m';
$str = 'the. book - 5. cost 7.55 dollars.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;