const regex = new RegExp('(?<!\\d)\\.(?!\\d)|[^a-zA-Z\\d. ]+', 'gm')
const str = `the. book - 5. cost 7.55 dollars.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);