const regex = /(?<=word[12]\/)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=word[12]\\\/)\\d+', 'gm')
const str = `https://www.pizza.com/word1/685185197419/word2/980054970331342/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}