re = /(?<=word[12]\/)\d+/m
str = 'https://www.pizza.com/word1/685185197419/word2/980054970331342/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end