$re = '/(?<=word[12]\/)\d+/m';
$str = 'https://www.pizza.com/word1/685185197419/word2/980054970331342/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);