re = /(?<=[\/]{2})([a-z-]{1,})(?=[\.|:])/
str = 'http://localhost:8080/test
https://test-app.uk.ru/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end