import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(a(?1)c|b)$";
final String string = "b\n"
+ "abc\n"
+ "aabcc\n"
+ "aaabccc\n"
+ "But does NOT match any of:\n\n"
+ "ab\n"
+ "bc\n"
+ "aabc\n"
+ "abcc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}