using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s-\s\d*.\d*\sMB";
string input = @"<a href=""http://example.com/a0j8nm5l3wo0"" target=_blank>01 song name.mp3 - 2.4 MB</a>
<a href=""http://example.com/ic1jfhhzzfth"" target=_blank>02 song name.mp3 - 4.0 MB</a>
<a href=""http://example.com/zo2nv6bzy6gd"" target=_blank>03 song name.mp3 - 3.3 MB</a>
<a href=""http://example.com/5fyony1m4j0w"" target=_blank>04 song name.mp3 - 3.5 MB</a>
<a href=""http://example.com/3imswet27clg"" target=_blank>05 song name.mp3 - 1.9 MB</a>
<a href=""http://example.com/ml65j3gpdggv"" target=_blank>06 song name.mp3 - 3.4 MB</a>
<a href=""http://example.com/hmuk8il0a04j"" target=_blank>07 song name.mp3 - 4.4 MB</a>
<a href=""http://example.com/qx81e67ystd3"" target=_blank>08 song name.mp3 - 3.9 MB</a>
<a href=""http://example.com/g6fo1s64vzkj"" target=_blank>09 song name.mp3 - 3.9 MB</a>
<a href=""http://example.com/xo3hw4xyx372"" target=_blank>10 song name.mp3 - 3.6 MB</a>
<a href=""http://example.com/ivcth22eqygd"" target=_blank>11 song name.mp3 - 3.3 MB</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}