// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s-\s\d*.\d*\sMB").unwrap();
let string = "<a href=\"http://example.com/a0j8nm5l3wo0\" target=_blank>01 song name.mp3 - 2.4 MB</a>
<a href=\"http://example.com/ic1jfhhzzfth\" target=_blank>02 song name.mp3 - 4.0 MB</a>
<a href=\"http://example.com/zo2nv6bzy6gd\" target=_blank>03 song name.mp3 - 3.3 MB</a>
<a href=\"http://example.com/5fyony1m4j0w\" target=_blank>04 song name.mp3 - 3.5 MB</a>
<a href=\"http://example.com/3imswet27clg\" target=_blank>05 song name.mp3 - 1.9 MB</a>
<a href=\"http://example.com/ml65j3gpdggv\" target=_blank>06 song name.mp3 - 3.4 MB</a>
<a href=\"http://example.com/hmuk8il0a04j\" target=_blank>07 song name.mp3 - 4.4 MB</a>
<a href=\"http://example.com/qx81e67ystd3\" target=_blank>08 song name.mp3 - 3.9 MB</a>
<a href=\"http://example.com/g6fo1s64vzkj\" target=_blank>09 song name.mp3 - 3.9 MB</a>
<a href=\"http://example.com/xo3hw4xyx372\" target=_blank>10 song name.mp3 - 3.6 MB</a>
<a href=\"http://example.com/ivcth22eqygd\" target=_blank>11 song name.mp3 - 3.3 MB</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}