#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d\n]*(\d)(?:[^\d\n]*\1)+[^\d\n]*$"
Local $sString = "00000000000000" & @CRLF & _
"(11)1111111111" & @CRLF & _
"22/ 222-2222222222" & @CRLF & _
"cell +33,333-3333-3333." & @CRLF & _
"14 244-44444 Ext. 444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")