re = /^[^\d\n]*(\d)(?:[^\d\n]*\1)+[^\d\n]*$/m
str = '00000000000000
(11)1111111111
22/ 222-2222222222
cell +33,333-3333-3333.
14 244-44444 Ext. 444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end