const regex = /^[^\d\n]*(\d)(?:[^\d\n]*\1)+[^\d\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d\\n]*(\\d)(?:[^\\d\\n]*\\1)+[^\\d\\n]*$', 'gm')
const str = `00000000000000
(11)1111111111
22/ 222-2222222222
cell +33,333-3333-3333.
14 244-44444 Ext. 444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}