package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`test\s([A-Z].+?)\s[a-z]`)
var str = `this is a test Ab Here here big`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}