$re = '/test\s([A-Z].+?)\s[a-z]/';
$str = 'this is a test Ab Here here big';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);