using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(start (nothing|var (bla)+)+ (end|final))+";
string input = @"start var blabla end
start nothing end";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}