package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(start (nothing|var (bla)+)+ (end|final))+`)
var str = `start var blabla end
start nothing end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}