package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?<\/a>(*SKIP)(*F)|\d{3}`)
var str = `lor <a>111</a> em 222 ip <a><link />333</a> sum 444 do <a>x555</a> lo <a>z 666</a> res`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}