re = /<a.*?<\/a>(*SKIP)(*F)|\d{3}/
str = 'lor <a>111</a> em 222 ip <a><link />333</a> sum 444 do <a>x555</a> lo <a>z 666</a> res'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end