const regex = /<a.*?<\/a>(*SKIP)(*F)|\d{3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?<\\\/a>(*SKIP)(*F)|\\d{3}', 'g')
const str = `lor <a>111</a> em 222 ip <a><link />333</a> sum 444 do <a>x555</a> lo <a>z 666</a> res`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}