using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ART\D\d{4}(.*?)\DAND";
string input = @"ART|3613{""currentTime"":""2016-02-29 20:57:06"",""chat"":{""user"":""SERVER"",""msg"":""asd""}}|AND ART|8923{""currentTime"":""2016-02-29 20:57:06"",""chat"":{""user"":""SERVER"",""msg"":""asd""}}|AND";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}