re = /ART\D\d{4}(.*?)\DAND/
str = 'ART|3613{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND ART|8923{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end