import Foundation
let pattern = #"ART\D\d{4}(.*?)\DAND"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ART|3613{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND ART|8923{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)