#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*)(^|$)"
Local $sString = " " & @CRLF & _
" " & @CRLF & _
"aaaa" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"aaa "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)