package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*)(^|$)`)
var str = `
aaaa
aaa `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}